mediastreamer: add dependency on host-vim
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 21 Aug 2017 20:55:16 +0000 (22:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Aug 2017 13:41:39 +0000 (15:41 +0200)
host-vim is needed to provide the xxd tool, otherwise the build fails
with:

checking for xxd... no
configure: error: "xxd is required (provided by vim package)"

This isn't noticed by the autobuilders, presumably because all of them
have vim installed locally.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mediastreamer/mediastreamer.mk

index 44d9e97461f4215d7bdb3277eb3a61dc1fa8a75a..1276cfae109a70df106bc1553b473f81376876b7 100644 (file)
@@ -7,7 +7,8 @@
 MEDIASTREAMER_VERSION = 2.14.0
 MEDIASTREAMER_SITE = http://download.savannah.nongnu.org/releases/linphone/mediastreamer
 MEDIASTREAMER_INSTALL_STAGING = YES
-MEDIASTREAMER_DEPENDENCIES = host-intltool host-pkgconf ortp host-gettext
+# host-vim needed for the xxd utility
+MEDIASTREAMER_DEPENDENCIES = host-intltool host-pkgconf ortp host-gettext host-vim
 # tests fail linking on some architectures, so disable them
 MEDIASTREAMER_CONF_OPTS = --disable-tests --disable-glx --disable-strict
 MEDIASTREAMER_LICENSE = GPL-2.0+