mplayer: make sure alsa-lib is installed before mplayer
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 1 Dec 2008 12:53:09 +0000 (12:53 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 1 Dec 2008 12:53:09 +0000 (12:53 -0000)
This patch adds alsa-lib to a dependency for mplayer if it is selected in
kconfig.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/multimedia/mplayer/mplayer.mk

index 47f2a86f714677e67f699198fc9af1a2b6a6ed5c..7e883279f6db1793f70f210cfdc324a12bc84ef2 100644 (file)
@@ -19,6 +19,10 @@ endif
 
 MPLAYER_DEP_LIBS:=libmad
 
+ifeq ($(strip $(BR2_PACKAGE_ALSA_LIB)),y)
+MPLAYER_DEP_LIBS+=alsa-lib
+endif
+
 $(DL_DIR)/$(MPLAYER_SOURCE):
        $(WGET) -P $(DL_DIR) $(MPLAYER_SITE)/$(MPLAYER_SOURCE)