fix configuration wrt elf2flt
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 28 Jan 2009 06:32:39 +0000 (06:32 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 28 Jan 2009 06:32:39 +0000 (06:32 -0000)
The buildroot toolchain is installed in $(STAGING_DIR)/usr/bin and not
in $(STAGING_DIR)/bin so let,s adjust the --prefix accordingly.

Also the BFLT binary format is always stripped by definition, so it is
incompatible with any kind of stripping option.

Signed-off-by: Nicolas Pitre <nico@cam.org>
Config.in
toolchain/elf2flt/elf2flt.mk

index 31cb70f095c671bf88d67934d006561269e9fd56..ee7a451346baa1e4eebd8b8e2b0495a5f30da924 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -243,14 +243,14 @@ choice
 
 config BR2_STRIP_strip
        bool "strip"
-       depends on !BR2_ENABLE_DEBUG
+       depends on !BR2_ENABLE_DEBUG &&  !BR2_ELF2FLT
        help
          strip   is the normal strip command
 
 config BR2_STRIP_sstrip
        bool "sstrip"
        select BR2_PACKAGE_SSTRIP_HOST
-       depends on !BR2_ENABLE_DEBUG
+       depends on !BR2_ENABLE_DEBUG && !BR2_ELF2FLT
        help
          sstrip  is a strip that discards more than the normal strip
 
index 30d7e839ad481678a7d9cef33751131f8a2c331d..f5a92b1f23441a9ca3cfa2ef6c5df828ab62a02b 100644 (file)
@@ -27,11 +27,11 @@ $(ELF2FLT_DIR)/.configured: $(ELF2FLT_DIR)/.patched
                LDFLAGS=-lz \
                $(ELF2FLT_DIR)/configure \
                --with-bfd-include-dir=$(BINUTILS_DIR1)/bfd/ \
-               --with-binutils-include-dir=$(BINUTILS_DIR)/include/ \
+               --with-binutils-include-dir=$(BINUTILS_DIR)/include/ \
                --target=$(REAL_GNU_TARGET_NAME) \
                --with-libbfd=$(BINUTILS_DIR1)/bfd/libbfd.a \
                --with-libiberty=$(BINUTILS_DIR1)/libiberty/libiberty.a \
-               --prefix=$(STAGING_DIR))
+               --prefix=$(STAGING_DIR)/usr)
        touch $@
 
 $(ELF2FLT_DIR)/$(ELF2FLT_BINARY): $(ELF2FLT_DIR)/.configured