openssl: re-enable parallel build
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Thu, 3 Dec 2015 21:31:16 +0000 (18:31 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Dec 2015 21:15:33 +0000 (22:15 +0100)
The previous incarnation was incomplete, it only applied one of the
Gentoo patches, hence it had corner cases.
Apply all 4 patches as pointed out by Mike on the mailing list.

Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openssl/0001-Dont-waste-time-building-manpages-if-we-re-not-going.patch
package/openssl/openssl.hash
package/openssl/openssl.mk

index e4dde7d02bb0ce10e80fcf09e9aa0304bd7bf39c..10d2b7526cf1100d7b3b7b43d4644bbd546978f8 100644 (file)
@@ -4,6 +4,7 @@ Date: Sat, 16 May 2015 18:53:51 +0200
 Subject: Dont waste time building manpages if we're not going to use em.
 
 Signed-off-by: Ryan Barnett <ryanbarnett3@gmail.com>
+[Gustavo: update for parallel-build]
 ---
  Makefile.org | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
@@ -16,8 +17,8 @@ index 60f07cc..976ceaf 100644
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
--install: all install_docs install_sw
-+install: all install_sw
+-install: install_docs install_sw
++install: install_sw
  
  install_sw:
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
index dee8ab962709a7554281be087da7f1c86b0c432f..2d2a5b0648a3c27914b0970263e251249c8273ac 100644 (file)
@@ -1,2 +1,7 @@
 # From https://www.openssl.org/source/openssl-1.0.2e.tar.gz.sha256
 sha256 e23ccafdb75cfcde782da0151731aa2185195ac745eea3846133f2e05c0e0bff        openssl-1.0.2e.tar.gz
+# Locally computed
+sha256 eddd8a5123748052c598214487ac178e4bfa4e31ba2ec520c70d59c8c5bfa2e9        openssl-1.0.2a-parallel-install-dirs.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d
+sha256 147c3eeaad614c044749ea527cb433eae5e2d5cad34a78c6ba61cd967bfbe01f        openssl-1.0.2a-parallel-obj-headers.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d
+sha256 30cb49489de5041841a74da9155cd4fabfbce33237262ba7cd23974314ae2956        openssl-1.0.2a-parallel-symlinking.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d
+sha256 deaf6f3af41874ecc6d63841ea14b8e6c71cea81d4a511a754bc90c9a993147f        openssl-1.0.2d-parallel-build.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d
index 1f07df19cf7ec2dba8ca3ebd7057715912898ce2..c3ea08d77d6287cb67bc75dc6650b756c9d3056c 100644 (file)
@@ -13,6 +13,11 @@ OPENSSL_DEPENDENCIES = zlib
 HOST_OPENSSL_DEPENDENCIES = host-zlib
 OPENSSL_TARGET_ARCH = generic32
 OPENSSL_CFLAGS = $(TARGET_CFLAGS)
+OPENSSL_PATCH = \
+       https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-libs/openssl/files/openssl-1.0.2d-parallel-build.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d \
+       https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-libs/openssl/files/openssl-1.0.2a-parallel-obj-headers.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d \
+       https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-libs/openssl/files/openssl-1.0.2a-parallel-install-dirs.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d \
+       https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-libs/openssl/files/openssl-1.0.2a-parallel-symlinking.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d
 
 ifeq ($(BR2_USE_MMU),)
 OPENSSL_CFLAGS += -DHAVE_FORK=0
@@ -98,23 +103,23 @@ OPENSSL_POST_CONFIGURE_HOOKS += OPENSSL_FIXUP_STATIC_MAKEFILE
 endif
 
 define HOST_OPENSSL_BUILD_CMDS
-       $(MAKE1) -C $(@D)
+       $(MAKE) -C $(@D)
 endef
 
 define OPENSSL_BUILD_CMDS
-       $(MAKE1) -C $(@D)
+       $(MAKE) -C $(@D)
 endef
 
 define OPENSSL_INSTALL_STAGING_CMDS
-       $(MAKE1) -C $(@D) INSTALL_PREFIX=$(STAGING_DIR) install
+       $(MAKE) -C $(@D) INSTALL_PREFIX=$(STAGING_DIR) install
 endef
 
 define HOST_OPENSSL_INSTALL_CMDS
-       $(MAKE1) -C $(@D) install
+       $(MAKE) -C $(@D) install
 endef
 
 define OPENSSL_INSTALL_TARGET_CMDS
-       $(MAKE1) -C $(@D) INSTALL_PREFIX=$(TARGET_DIR) install
+       $(MAKE) -C $(@D) INSTALL_PREFIX=$(TARGET_DIR) install
        rm -rf $(TARGET_DIR)/usr/lib/ssl
        rm -f $(TARGET_DIR)/usr/bin/c_rehash
 endef