package/libarchive: remove double handling of zstd
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 25 Apr 2020 19:23:29 +0000 (21:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 25 Apr 2020 19:23:29 +0000 (21:23 +0200)
When 4bcc34446485d27efd41de70a86355a0e3798838 was applied, it was not
noticed that 96dc6701af877a4aa4da20a9e0d5b849cc5c8356 (from another
contributor) had already been
applied. 4bcc34446485d27efd41de70a86355a0e3798838 essentially did the
same thing as 96dc6701af877a4aa4da20a9e0d5b849cc5c8356, except it also
disable zstd support explicitly in the host-libarchive package.

Let's drop the part of 4bcc34446485d27efd41de70a86355a0e3798838 that
duplicates 96dc6701af877a4aa4da20a9e0d5b849cc5c8356.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libarchive/libarchive.mk

index 516d929763a9ddbdadd0259930e97c8460c5f8ce..89eeffe92e71c04dcae1f3049e8fcabb3f5ff43d 100644 (file)
@@ -111,13 +111,6 @@ else
 LIBARCHIVE_CONF_OPTS += --without-zlib
 endif
 
-ifeq ($(BR2_PACKAGE_ZSTD),y)
-LIBARCHIVE_CONF_OPTS += --with-zstd
-LIBARCHIVE_DEPENDENCIES += zstd
-else
-LIBARCHIVE_CONF_OPTS += --without-zstd
-endif
-
 # libarchive requires LZMA with thread support in the toolchain
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS)$(BR2_PACKAGE_XZ),yy)
 LIBARCHIVE_DEPENDENCIES += xz