package/haproxy: set USE_DL if needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 14 Jul 2020 17:25:29 +0000 (19:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 14 Jul 2020 19:52:45 +0000 (21:52 +0200)
haproxy uses dladdr since version 2.2.0 and
http://git.haproxy.org/?p=haproxy.git;a=commit;h=eb8b1ca3eb4c8d4688e1a4a1d9c1b91f68324e09

So set USE_DL to enable linking with -ldl

Fixes:
 - http://autobuild.buildroot.org/results/7bb76153b7dd8f392b247569c53d0f4cbf408371

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/haproxy/haproxy.mk

index 6f97840f6dceab68a3a8602124d2dce3f46fe61a..e11abe7845e29e2533c77ae5e00ab552e1d83094 100644 (file)
@@ -15,6 +15,10 @@ HAPROXY_MAKE_OPTS = \
        PREFIX=/usr \
        TARGET=custom
 
+ifeq ($(BR2_STATIC_LIBS),)
+HAPROXY_MAKE_OPTS += USE_DL=1
+endif
+
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 HAPROXY_LIBS += -latomic
 endif