libopenmax: Add libopenmax virtual package
authorSpenser Gilliland <spenser@gillilanding.com>
Thu, 30 May 2013 06:30:36 +0000 (06:30 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 May 2013 19:36:16 +0000 (21:36 +0200)
this adds the libopenmax virtual package for hardware based video acceleration

[Peter: fix openmax-without-any-backends check]
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/bellagio/Config.in
package/opengl/Config.in
package/opengl/libopenmax/libopenmax.mk [new file with mode: 0644]
package/rpi-userland/Config.in

index 1458f63702d2adbd20d3c5651a5b8b1a27810136..d918f80ce3052a4b21b86d16c0083715f17803d1 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_BELLAGIO
        bool "bellagio"
        depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_HAS_OPENMAX
        help
          Bellagio is an opensource implementation of the
          OpenMAX IL API.
index 81616f99fb816c97be691bd38a807a631805919f..1636807a84324006188486275764757eeaa2e2cf 100644 (file)
@@ -6,3 +6,6 @@ config BR2_PACKAGE_HAS_OPENGL_ES
 
 config BR2_PACKAGE_HAS_OPENVG
        bool
+
+config BR2_PACKAGE_HAS_OPENMAX
+       bool
diff --git a/package/opengl/libopenmax/libopenmax.mk b/package/opengl/libopenmax/libopenmax.mk
new file mode 100644 (file)
index 0000000..4307602
--- /dev/null
@@ -0,0 +1,24 @@
+#############################################################
+#
+# Virtual package for libopenmax
+#
+#############################################################
+
+LIBOPENMAX_SOURCE =
+
+ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
+LIBOPENMAX_DEPENDENCIES += rpi-userland
+endif
+
+ifeq ($(BR2_PACKAGE_BELLAGIO),y)
+LIBOPENMAX_DEPENDENCIES += bellagio
+endif
+
+ifeq ($(LIBOPENMAX_DEPENDENCIES),)
+define LIBOPENMAX_CONFIGURE_CMDS
+       echo "No libopenmax implementation selected. Configuration error."
+       exit 1
+endef
+endif
+
+$(eval $(generic-package))
index 2c35fb76c87ab37e7108eafb76a35c7647a1a156..da5726f2e47230faca65a7077930498f6dcca5da 100644 (file)
@@ -6,6 +6,7 @@ config BR2_PACKAGE_RPI_USERLAND
        select BR2_PACKAGE_HAS_OPENGL_EGL
        select BR2_PACKAGE_HAS_OPENGL_ES
        select BR2_PACKAGE_HAS_OPENVG
+       select BR2_PACKAGE_HAS_OPENMAX
        help
          Raspberry Pi Userland contains the necessary library to use the
          VideoCore driver.