* Fix format of the pciutils pci.ids.gz data file
authorNigel Kukard <nkukard@lbsd.net>
Fri, 2 Jan 2009 12:01:49 +0000 (12:01 -0000)
committerNigel Kukard <nkukard@lbsd.net>
Fri, 2 Jan 2009 12:01:49 +0000 (12:01 -0000)
- If ZLIB is present the filename of pci.ids is changed to pci.ids.gz but its not compressed, add a compressor to ensure its gzipped

package/pciutils/pciutils.mk

index f9cc6bc86f861eef3fd6f9bdb184b9abb7c1866d..8d2ad67aec19a7fead4446453eeccb72dab30ca6 100644 (file)
@@ -17,9 +17,11 @@ PCIIDS_CAT:=$(BZCAT)
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 PCIUTILS_HAVE_ZLIB=yes
 PCIIDS_FILE=pci.ids.gz
+PCIIDS_COMPRESSOR=gzip -9 -c
 else
 PCIUTILS_HAVE_ZLIB=no
 PCIIDS_FILE=pci.ids
+PCIIDS_COMPRESSOR=cat
 endif
 
 $(DL_DIR)/$(PCIUTILS_SOURCE):
@@ -30,7 +32,7 @@ $(DL_DIR)/$(PCIIDS_SOURCE):
 
 $(PCIUTILS_DIR)/.unpacked: $(DL_DIR)/$(PCIUTILS_SOURCE) $(DL_DIR)/$(PCIIDS_SOURCE)
        $(PCIUTILS_CAT) $(DL_DIR)/$(PCIUTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PCIIDS_CAT) $(DL_DIR)/$(PCIIDS_SOURCE) > $(PCIUTILS_DIR)/$(PCIIDS_FILE)
+       $(PCIIDS_CAT) $(DL_DIR)/$(PCIIDS_SOURCE) | $(PCIIDS_COMPRESSOR) > $(PCIUTILS_DIR)/$(PCIIDS_FILE)
        toolchain/patch-kernel.sh $(PCIUTILS_DIR) package/pciutils pciutils-$(PCIUTILS_VERSION)\*.patch
        #$(CONFIG_UPDATE) $(@D)
        $(SED) 's/uname -s/echo Linux/' \