package/kodi: remove X11-based OpenGL ES support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 1 Apr 2018 13:01:07 +0000 (15:01 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 13:22:28 +0000 (14:22 +0100)
To prepare the bump to the next Kodi version 18.0-Leia we remove the
current OpenGL ES support options. Kodi 18.0 will bring a major
overhaul of the supported windowing platforms, x11-based gles support
was removed, see upstream PR 12196.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/kodi/Config.in
package/kodi/kodi.mk

index e84f5c4014ee8d9e63d18aab02404924c45da2f7..700b1e459d1af4fa3ed2eabb132734099c6b2118 100644 (file)
@@ -15,21 +15,14 @@ comment "kodi needs python w/ .py modules, a uClibc or glibc toolchain w/ C++, t
                || !BR2_PACKAGE_PYTHON \
                || BR2_PACKAGE_PYTHON_PYC_ONLY
 
-config BR2_PACKAGE_KODI_EGL_GLES
-       bool
-       default y
-       depends on BR2_PACKAGE_HAS_LIBEGL
-       depends on BR2_PACKAGE_HAS_LIBGLES
-       depends on !BR2_PACKAGE_KODI_GL_EGL # prefer GL if available
-
 config BR2_PACKAGE_KODI_GL_EGL
        bool
        default y
        depends on BR2_PACKAGE_HAS_LIBEGL
        depends on BR2_PACKAGE_HAS_LIBGL
 
-comment "kodi needs an OpenGL EGL with either an openGL or an OpenGL ES backend"
-       depends on !BR2_PACKAGE_KODI_GL_EGL && !BR2_PACKAGE_KODI_EGL_GLES
+comment "kodi needs an OpenGL EGL backend with OpenGL support"
+       depends on !BR2_PACKAGE_KODI_GL_EGL
 
 menuconfig BR2_PACKAGE_KODI
        bool "kodi"
@@ -38,7 +31,7 @@ menuconfig BR2_PACKAGE_KODI
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on !BR2_TOOLCHAIN_USES_MUSL
-       depends on BR2_PACKAGE_KODI_EGL_GLES || BR2_PACKAGE_KODI_GL_EGL
+       depends on BR2_PACKAGE_KODI_GL_EGL
        depends on BR2_USE_WCHAR
        depends on !BR2_STATIC_LIBS # gnutls, python and others
        depends on BR2_PACKAGE_KODI_ARCH_SUPPORTS
index 8d2430ea557702ff12f476b5c5b270c7041d3539..7039e35ed613bd0f9e6ce907c79413f864e9daea 100644 (file)
@@ -258,16 +258,6 @@ else
 KODI_CONF_OPTS += -DENABLE_OPENGL=OFF -DENABLE_X11=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_KODI_EGL_GLES),y)
-KODI_DEPENDENCIES += libegl libgles
-KODI_CONF_OPTS += \
-       -DENABLE_OPENGLES=ON
-KODI_C_FLAGS += `$(PKG_CONFIG_HOST_BINARY) --cflags --libs egl`
-KODI_CXX_FLAGS += `$(PKG_CONFIG_HOST_BINARY) --cflags --libs egl`
-else
-KODI_CONF_OPTS += -DENABLE_OPENGLES=OFF
-endif
-
 ifeq ($(BR2_PACKAGE_KODI_LIBMICROHTTPD),y)
 KODI_CONF_OPTS += -DENABLE_MICROHTTPD=ON
 KODI_DEPENDENCIES += libmicrohttpd