package/open2300: fix static builds
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 4 Jul 2016 13:05:17 +0000 (15:05 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Jul 2016 13:27:49 +0000 (15:27 +0200)
Fixes http://autobuild.buildroot.org/results/036/036c9088cfaae421c15b650f35e7ffe6ab934031/

libmysqlclient needs -lz to build, so we have to pass it explicitly for
static builds.

For almost-two-and-a-half years this error has been happenning, noone
ever tried to fix it. This is now done, at last! ;-]

[Peter: add autobuilder reference]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/open2300/open2300.mk

index 73db2a0023514e6b30e2f9d3a57256d2b843dcc7..323f566cb4aca9a51a372e9515792743778ddc3d 100644 (file)
@@ -21,6 +21,10 @@ OPEN2300_DEPENDENCIES += mysql
 OPEN2300_BINS += mysql2300 mysqlhistlog2300
 OPEN2300_CFLAGS += -I$(STAGING_DIR)/usr/include/mysql
 OPEN2300_LDFLAGS += -L$(STAGING_DIR)/usr/lib/mysql -lmysqlclient
+ifeq ($(BR2_STATIC_LIBS),y)
+# mysql needs -lz, so we need to specify it for static builds
+OPEN2300_LDFLAGS += -lz
+endif
 endif
 
 define OPEN2300_BUILD_CMDS