package/mtd: make ubihealthd independent of ubifs
authorBaruch Siach <baruch@tkos.co.il>
Fri, 27 Aug 2021 05:02:40 +0000 (08:02 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 27 Aug 2021 20:53:23 +0000 (22:53 +0200)
Since version 2.1.3 ubihealthd can be enabled without of ubifs-utils.

This also fixes usability of enabling BR2_PACKAGE_MTD_UBIHEALTHD.
BR2_PACKAGE_MTD_UBIFS_UTILS is a blind option. The only way to enable it
is to enable BR2_PACKAGE_MTD_MKFSUBIFS that selects it. ubihealthd
dependency on BR2_PACKAGE_MTD_UBIFS_UTILS makes enabling it unintuitive.

Cc: Markus Mayer <mmayer@broadcom.com>
Cc: Matt Weber <matthew.weber@collins.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/mtd/Config.in
package/mtd/mtd.mk

index 57ad01971d5fc1bb76733d6202310c6c78c3902e..d0ca3ba6631d562b9b0ee924da214c789b058089 100644 (file)
@@ -146,7 +146,6 @@ config BR2_PACKAGE_MTD_UBIFORMAT
 config BR2_PACKAGE_MTD_UBIHEALTHD
        bool "ubihealthd"
        default y
-       depends on BR2_PACKAGE_MTD_UBIFS_UTILS
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17 # getrandom()
 
 config BR2_PACKAGE_MTD_UBIMKVOL
index a37594b1641925ef34c1c9ed4f21ac308cfe17b8..6385b9ee0a2ca64514d088d0d9230275501b2632 100644 (file)
@@ -40,6 +40,12 @@ else
 MTD_CONF_OPTS += --without-ubifs
 endif
 
+ifeq ($(BR2_PACKAGE_MTD_UBIHEALTHD),y)
+MTD_CONF_OPTS += --enable-ubihealthd
+else
+MTD_CONF_OPTS += --disable-ubihealthd
+endif
+
 ifeq ($(BR2_PACKAGE_MTD_TESTS),y)
 MTD_CONF_OPTS += --enable-tests --enable-install-tests
 else