pkg-autotools: fix patching libtool for version 2.4
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 26 Jan 2015 23:30:24 +0000 (00:30 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Feb 2015 21:25:25 +0000 (22:25 +0100)
If the libtool used by the package is 2.4 (i.e. with no patchlevel), we
end up with a confusing message:

    /bin/sh: line 0: test: -gt: unary operator expected

That's because patchlevel is empty, and thus there is nothing to comapre
to 2, and test complains.

Fake a patchlevel of 0 (which is really what a missing patchlevel means
anyway) in that case.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-autotools.mk

index b20e20ef418551ad094208b2594299e64ae02c32..b6b83f810f52555ba876242dac99299580dc4fbb 100644 (file)
@@ -69,7 +69,7 @@ define LIBTOOL_PATCH_HOOK
                elif test $${ltmain_version} = "2.2"; then\
                        $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v2.2.patch; \
                elif test $${ltmain_version} = "2.4"; then\
-                       if test $${ltmain_patchlevel} -gt 2; then\
+                       if test $${ltmain_patchlevel:-0} -gt 2; then\
                                $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v2.4.4.patch; \
                        else \
                                $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v2.4.patch; \