package/mesa3d: always enable openGL
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 19 Apr 2014 22:01:43 +0000 (00:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Apr 2014 22:04:38 +0000 (00:04 +0200)
Currently, we only pass --enable-opengl is at least one DRI driver is
enabled, since full OpenGL is only possible with a DRI driver (and the
X.Org stack). Otherwise, we pass --disable-opengl on the assumption that
OpenGL is not possible.

But mesa3d's ./configure is a bit weird: enabling OpenGL-ES and diabling
full OpenGL is an error (see autobuild failure below).

It turns out that, if there is no DRI driver enabled, but --enable-opengl
is passed, ./configure will behave properly wrt OpenGL-ES, and will not
build the full OpenGL libgl.

Thanks to Paul for explaining this.

Fixes:
    http://autobuild.buildroot.net/results/61c/61c1c566dc0e829cb663ca30b1fd6cf9cc6cd931/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index db166f86e9348b9a552d3814658aaf6ba0584f3a..a09e4c6608aca376342de40bd2dd1cf20c1c6461 100644 (file)
@@ -80,13 +80,10 @@ endif
 
 # APIs
 
-# Full OpenGL is provided by DRI drivers with X.Org; DRI drivers are only
-# enabled when X.Org is enabled anyway, so no need to check for X.Org here.
-ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),y)
+# Always enable OpenGL:
+#   - it is needed for GLES (mesa3d's ./configure is a bit weird)
+#   - but if no DRI driver is enabled, then libgl is not built
 MESA3D_CONF_OPT += --enable-opengl
-else
-MESA3D_CONF_OPT += --disable-opengl
-endif
 
 ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL),y)
 # egl depends on gbm, gbm depends on udev