php: security bump to version 7.0.12
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 13 Oct 2016 22:39:26 +0000 (19:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 14 Oct 2016 07:26:35 +0000 (09:26 +0200)
See http://www.php.net/ChangeLog-7.php#7.0.12 since there are no CVEs
out yet.

And drop upstream patch.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/0007-phpdbg_prompt-enclose-phpdbg_load_module_or_extensio.patch [deleted file]
package/php/php.hash
package/php/php.mk

diff --git a/package/php/0007-phpdbg_prompt-enclose-phpdbg_load_module_or_extensio.patch b/package/php/0007-phpdbg_prompt-enclose-phpdbg_load_module_or_extensio.patch
deleted file mode 100644 (file)
index 006a034..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-From 9ca3de0446fcd31b1561b333020ae0674a83bec7 Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Tue, 9 Aug 2016 11:39:10 +0200
-Subject: [PATCH] phpdbg_prompt: enclose phpdbg_load_module_or_extension() in
- HAVE_LIBDL
-
-The phpdbg_load_module_or_extension() function relies on libdl
-functionality, so it should be enclosed in HAVE_LIBDL to avoid the
-following build failure when libdl support is not available:
-
-php-7.0.9/sapi/phpdbg/phpdbg_prompt.c:(.text+0x1c20): undefined reference to `_DL_LOAD'
-php-7.0.9/sapi/phpdbg/phpdbg_prompt.c:(.text+0x1c36): undefined reference to `_GET_DL_ERROR'
-php-7.0.9/sapi/phpdbg/phpdbg_prompt.c:(.text+0x1c6a): undefined reference to `_DL_FETCH_SYMBOL'
-php-7.0.9/sapi/phpdbg/phpdbg_prompt.c:(.text+0x1c7e): undefined reference to `_DL_FETCH_SYMBOL'
-php-7.0.9/sapi/phpdbg/phpdbg_prompt.c:(.text+0x1dc6): undefined reference to `_DL_UNLOAD'
-
-This function is only called in the "dl" debug command, inside an
-HAVE_LIBDL condition.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- sapi/phpdbg/phpdbg_prompt.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/sapi/phpdbg/phpdbg_prompt.c b/sapi/phpdbg/phpdbg_prompt.c
-index 6f73d30..6768dc5 100644
---- a/sapi/phpdbg/phpdbg_prompt.c
-+++ b/sapi/phpdbg/phpdbg_prompt.c
-@@ -1019,6 +1019,7 @@ static int add_zendext_info(zend_extension *ext) /* {{{ */ {
- }
- /* }}} */
-+#ifdef HAVE_LIBDL
- PHPDBG_API const char *phpdbg_load_module_or_extension(char **path, char **name) /* {{{ */ {
-       DL_HANDLE handle;
-       char *extension_dir;
-@@ -1158,6 +1159,7 @@ quit:
-       DL_UNLOAD(handle);
-       return NULL;
- }
-+#endif
- /* }}} */
- PHPDBG_COMMAND(dl) /* {{{ */
--- 
-2.7.4
-
index 0092095009df253e9c2f44d6a76c2d9b3e60dc14..dde6a64dc30d9542fc2b6849094ca2f959a97250 100644 (file)
@@ -1,2 +1,2 @@
 # From http://php.net/downloads.php
-sha256 d4cccea8da1d27c11b89386f8b8e95692ad3356610d571253d00ca67d524c735  php-7.0.11.tar.xz
+sha256 f3d6c49e1c242e5995dec15e503fde996c327eb86cd7ec45c690e93c971b83ff  php-7.0.12.tar.xz
index b1b19ada7c9fbe3f46120df9eb3e6d8ace9f51ba..f925ec1eba3bbd9094a65873e55afe5075fd6cb1 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-PHP_VERSION = 7.0.11
+PHP_VERSION = 7.0.12
 PHP_SITE = http://www.php.net/distributions
 PHP_SOURCE = php-$(PHP_VERSION).tar.xz
 PHP_INSTALL_STAGING = YES