package/neofetch: new package
authorChristian Stewart <christian@paral.in>
Fri, 15 Jan 2021 19:35:39 +0000 (11:35 -0800)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 17 Jan 2021 11:16:47 +0000 (12:16 +0100)
Signed-off-by: Christian Stewart <christian@paral.in>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/Config.in
package/neofetch/Config.in [new file with mode: 0644]
package/neofetch/neofetch.hash [new file with mode: 0644]
package/neofetch/neofetch.mk [new file with mode: 0644]

index 81ad4979a1cb0f86d4f75a14c208d110846f48b7..54b917b736a9aa507a3ed615a0a14022d1347301 100644 (file)
@@ -2379,6 +2379,7 @@ comment "Utilities"
        source "package/lockfile-progs/Config.in"
        source "package/logrotate/Config.in"
        source "package/logsurfer/Config.in"
+       source "package/neofetch/Config.in"
        source "package/pdmenu/Config.in"
        source "package/pinentry/Config.in"
        source "package/qprint/Config.in"
diff --git a/package/neofetch/Config.in b/package/neofetch/Config.in
new file mode 100644 (file)
index 0000000..409466b
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_NEOFETCH
+       bool "neofetch"
+       depends on BR2_USE_MMU # bash
+       depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # bash
+       select BR2_PACKAGE_BASH # runtime dependency
+       help
+         Neofetch is a bash script to display system information,
+         including hardware, in a visually pleasing way.
+
+         https://github.com/dylanaraps/neofetch
diff --git a/package/neofetch/neofetch.hash b/package/neofetch/neofetch.hash
new file mode 100644 (file)
index 0000000..0927715
--- /dev/null
@@ -0,0 +1,2 @@
+sha256  58a95e6b714e41efc804eca389a223309169b2def35e57fa934482a6b47c27e7  neofetch-7.1.0.tar.gz
+sha256  fc3034b3dd3a08db109949b629210213bba52aa95455cbc5c2fefa2fc1183efe  LICENSE.md
diff --git a/package/neofetch/neofetch.mk b/package/neofetch/neofetch.mk
new file mode 100644 (file)
index 0000000..4ea6c27
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# neofetch
+#
+################################################################################
+
+NEOFETCH_VERSION = 7.1.0
+NEOFETCH_SITE = $(call github,dylanaraps,neofetch,$(NEOFETCH_VERSION))
+NEOFETCH_LICENSE = MIT
+NEOFETCH_LICENSE_FILES = LICENSE.md
+
+define NEOFETCH_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/neofetch \
+               $(TARGET_DIR)/usr/bin/neofetch
+endef
+
+$(eval $(generic-package))