package/mender: remove tenant.conf
authorMirza Krak <mirza.krak@northern.tech>
Mon, 20 Aug 2018 13:09:08 +0000 (15:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 Aug 2018 14:55:01 +0000 (16:55 +0200)
Tenant Token is a configuration option that has to do with Hosted Mender,
where you you need to set this for the devices to connect to the
correct organization in a multi-tenant system.

The removal of tenant.conf usage (and /var/lib/mender/authtentoken)
was in Mender client version 1.2.0, where it was switched to be an mender.conf
option instead as the example above demonstrates. As the first version that was
integrated in Buildroot was 1.4.0, the inclusion of tenant.conf and the
creation of the symlink is not necessary.

Now it is specified as such in mender.conf:

Example:

/etc/mender/mender.conf
{
    TenantToken: "very long base64 encoded string"
}

Signed-off-by: Mirza Krak <mirza.krak@northern.tech>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mender/mender.mk
package/mender/mender.service
package/mender/tenant.conf [deleted file]

index a90ca3d2a882340b549c6f30370869c1f0ad1f25..a7ae1d388a44ecbd884dcdf134d3e56910fc532b 100644 (file)
@@ -13,8 +13,7 @@ define MENDER_INSTALL_CONFIG_FILES
 
        $(INSTALL) -D -m 0644 package/mender/mender.conf \
                $(TARGET_DIR)/etc/mender/mender.conf
-       $(INSTALL) -D -m 0644 package/mender/tenant.conf \
-               $(TARGET_DIR)/etc/mender/tenant.conf
+
        $(INSTALL) -D -m 0644 package/mender/server.crt \
                $(TARGET_DIR)/etc/mender/server.crt
 
index ec77fbc46c4f9077e287522432f31d4414b51c37..9ede55acb5e692887becf4d84805c329ac84466d 100644 (file)
@@ -7,7 +7,6 @@ Type=idle
 User=root
 Group=root
 ExecStartPre=/bin/mkdir -p -m 0700 /data/mender
-ExecStartPre=/bin/ln -sf /etc/mender/tenant.conf /var/lib/mender/authtentoken
 ExecStart=/usr/bin/mender -daemon
 Restart=on-abort
 
diff --git a/package/mender/tenant.conf b/package/mender/tenant.conf
deleted file mode 100644 (file)
index e69de29..0000000