dnsmasq: use new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:42:08 +0000 (22:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:24 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dnsmasq/Config.in
package/dnsmasq/dnsmasq.mk

index 936b1de5098880dc5ba809e75e66955c6b98a02e..8921fc629dba023829ea6bb752d89037b23e12ec 100644 (file)
@@ -31,7 +31,6 @@ config BR2_PACKAGE_DNSMASQ_IDN
        bool "IDN support"
        depends on BR2_USE_WCHAR
        select BR2_PACKAGE_LIBIDN
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          Enable IDN support in dnsmasq.
          This option is a big space taker since it pulls in many
index c6f15e2ea2db2e0b0b039bfd97f6024a369309b8..00a59dac01134b8b47dbb54b4be60062c13cd6b0 100644 (file)
@@ -32,8 +32,8 @@ endif
 
 # NLS requires IDN so only enable it (i18n) when IDN is true
 ifeq ($(BR2_PACKAGE_DNSMASQ_IDN),y)
-DNSMASQ_DEPENDENCIES += libidn $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) host-gettext
-DNSMASQ_MAKE_OPTS += LIBS+="$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)"
+DNSMASQ_DEPENDENCIES += libidn $(TARGET_NLS_DEPENDENCIES)
+DNSMASQ_MAKE_OPTS += LIBS+=$(TARGET_NLS_LIBS)
 DNSMASQ_COPTS += -DHAVE_IDN
 DNSMASQ_I18N = $(if $(BR2_ENABLE_LOCALE),-i18n)
 endif