Valgrind works on PPC and AMD64 as well nowadays.
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Sep 2006 08:48:47 +0000 (08:48 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Sep 2006 08:48:47 +0000 (08:48 -0000)
Use Kconfig to ensure valgrind can only be enabled on supported archs.

package/valgrind/Config.in
package/valgrind/valgrind.mk

index 779cdd7444391fbe3d288b7c7f42f47fd48f1ac2..4eb6a9b695c8612b1e4e8e9c835d361c18e4d01f 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_VALGRIND
        bool "valgrind"
        default n
+       depends BR2_i386 || BR2_powerpc || BR2_x86_64
        help
          Tool for debugging and profiling Linux programs.
 
index ace6b56abbc8ae6a4b3edc2603a21a3398e63905..9b0ae29fe2761f2627ec946de4d24399ca51703b 100644 (file)
@@ -77,11 +77,7 @@ $(TARGET_DIR)/usr/bin/valgrind: $(VALGRIND_DIR)/none/vgskin_none.so
        #cp $(VALGRIND_DIR)/woody.supp $(TARGET_DIR)/usr/lib/valgrind/
        touch -c $(TARGET_DIR)/usr/bin/valgrind
 
-ifeq ($(BR2_i386),y)
 valgrind: $(TARGET_DIR)/usr/bin/valgrind
-else
-valgrind:
-endif
 
 valgrind-source: $(DL_DIR)/$(VALGRIND_SOURCE)