package/ncurses: don't attempt calling ldconfig in host-ncurses
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Wed, 9 Dec 2020 14:59:23 +0000 (15:59 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 21 Dec 2020 09:26:24 +0000 (10:26 +0100)
The host-ncurses install step attempts to run ldconfig, causing a permission
failure:

cd /buildroot/output/host/lib && (ln -s -f libncurses.so.6.0 libncurses.so.6; ln -s -f libncurses.so.6 libncurses.so; )
test -z "" && /sbin/ldconfig
/sbin/ldconfig: Can't create temporary cache file /etc/ld.so.cache~: Permission denied
make[3]: [/buildroot/output/host/lib/libncurses.so.6.0] Error 1 (ignored)

The error is non-fatal and ignored, but confusing.

The ncurses makefiles already avoid calling ldconfig when DESTDIR is set
(target case) but for host-ncurses DESTDIR is empty and the output/host path
is passed via --prefix.

Pass an empty ac_cv_path_LDCONFIG to the configure step, so than ldconfig is
not called.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ncurses/ncurses.mk

index f4e4784a3cc165438f07f3f6a7baee0b230c3966..4d8dcecc3ac73cbf8d5f901532b3a4b9e70e9f7c 100644 (file)
@@ -187,6 +187,9 @@ define HOST_NCURSES_BUILD_CMDS
        $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/progs tic
 endef
 
+HOST_NCURSES_CONF_ENV = \
+       ac_cv_path_LDCONFIG=""
+
 HOST_NCURSES_CONF_OPTS = \
        --with-shared \
        --without-gpm \