core/pkg-infra: prepare for alternate default source archives
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 25 Mar 2019 19:59:20 +0000 (20:59 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 10 Jan 2021 18:42:04 +0000 (19:42 +0100)
The .tar.gz default extension is historical, and we initially used
to only fetch tarballs from remote sites.

When we introduced downloads from VCS repositories, we kept that
extension, and kept compressing with gz, by lack of good reason to
switch to some other compression scheme.

However, nowadays, we will want to change the way we construct the
tarballs we generate from VCS. This will de facto change the hashes
of those tarballs.

So we will want that the archives we generate do not clash with the
existing ones, so we need another filename. Thus, we need a way to
be able to use a different extension when we generate archives from
VCS.

Use a macro as suggested by Arnout.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Vincent Fazio <vfazio@xes-inc.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: Vincent Fazio <vfazio@xes-inc.com>
package/pkg-generic.mk
package/pkg-utils.mk

index 621fb9142453ed0def0e3813fbe22a999f15fc48..c46c74235239bf1dd8bc5e46f3507d15ec8157c9 100644 (file)
@@ -518,7 +518,7 @@ ifndef $(2)_SOURCE
  ifdef $(3)_SOURCE
   $(2)_SOURCE = $$($(3)_SOURCE)
  else ifdef $(2)_VERSION
-  $(2)_SOURCE                  ?= $$($(2)_BASENAME_RAW).tar.gz
+  $(2)_SOURCE                  ?= $$($(2)_BASENAME_RAW)$$(call pkg_source_ext,$(2))
  endif
 endif
 
index a2cc160d0b7fb3260ede76963f44f75c1abb8c5b..c7597a3a45d543e740b91c77c6d8b4cb5c519c79 100644 (file)
@@ -40,6 +40,11 @@ KCONFIG_DISABLE_OPT = $(call KCONFIG_MUNGE_DOT_CONFIG, $(1), $(SHARP_SIGN) $(1)
 pkgdir = $(dir $(lastword $(MAKEFILE_LIST)))
 pkgname = $(lastword $(subst /, ,$(pkgdir)))
 
+# Helper to build the extension for a package archive, based on various
+# conditions.
+# $(1): upper-case package name
+pkg_source_ext = .tar.gz
+
 # Define extractors for different archive suffixes
 INFLATE.bz2  = $(BZCAT)
 INFLATE.gz   = $(ZCAT)