python-twisted: add missing dependency on host-python-incremental
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Jul 2017 17:27:27 +0000 (19:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Jul 2017 17:27:27 +0000 (19:27 +0200)
The recent change on PYTHONPATH for Python 2.x has revealed a missing
dependency in the python-twisted package. The incremental Python
module is listed in both setup_requires and install_requires, so we
must depend on both its target *and* host variants.

Fixes:

  http://autobuild.buildroot.net/results/386bf87abba550b5477d5e15e57981b8c3cef8d6/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-twisted/python-twisted.mk

index b167a0f3b81e1965ea93b86d1951dfe711e99434..9b3ced57b99c6884719bac9a10e04ba769a30374 100644 (file)
@@ -10,6 +10,6 @@ PYTHON_TWISTED_SITE = https://pypi.python.org/packages/d2/5d/ed5071740be94da6255
 PYTHON_TWISTED_SETUP_TYPE = setuptools
 PYTHON_TWISTED_LICENSE = MIT
 PYTHON_TWISTED_LICENSE_FILES = LICENSE
-PYTHON_TWISTED_DEPENDENCIES = python-incremental
+PYTHON_TWISTED_DEPENDENCIES = python-incremental host-python-incremental
 
 $(eval $(python-package))