dhrystone: pass HZ=100 to fix build issue on musl
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 13 Sep 2015 21:13:20 +0000 (23:13 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 13 Sep 2015 21:13:20 +0000 (23:13 +0200)
Fixes:
http://autobuild.buildroot.net/results/1b6cb1b40431bf484db2d99bfdc8237cbae6a9d7/
http://autobuild.buildroot.net/results/20e669d6e4bc3d872a355ef658ddad8f34676624/

musl doesn't provide sys/param.h to figure out the value of HZ, but as we
know we are building for Linux, and on Linux the clock_t values returned
from times(2) are defined in terms of USER_HZ which is always 100, we can
just as well tell dhrystone to use that directly.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dhrystone/Makefile

index d628ddb507ef189838f825ecd9365671b67c558b..f7a212b2fea61e63c1de17c256df74d5d62f3ef4 100644 (file)
@@ -1,4 +1,4 @@
-CPPFLAGS += -DNO_PROTOTYPES=1
+CPPFLAGS += -DNO_PROTOTYPES=1 -DHZ=100
 LDLIBS += -lm
 
 all: dhrystone