bison: remove deprecated target package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 15 Jan 2015 14:30:19 +0000 (11:30 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 25 Jan 2015 23:15:45 +0000 (00:15 +0100)
It's been deprecated for a year now so remove the target variant.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/bison/Config.in [deleted file]
package/bison/bison.mk

index 50591af17331dff327c58797547d2c863ac78d4b..243416ee52e7b51b907500a12935333bb9f9c7be 100644 (file)
@@ -102,6 +102,14 @@ endif
 
 comment "Legacy options removed in 2015.02"
 
+config BR2_PACKAGE_BISON
+       bool "bison target package removed"
+       select BR2_LEGACY
+       help
+         The bison target package has been removed, it's been
+         deprecated for some time now and is essentially a development
+         tool which isn't very useful in the target.
+
 config BR2_PACKAGE_GOB2
        bool "gob2 target package removed"
        select BR2_LEGACY
index d3d2f39934506ba1381e42b950e4a0171cc8cf48..2dc0ac654b0ab13d6bdb252d3f68ca9e39f5e82d 100644 (file)
@@ -102,7 +102,6 @@ endmenu
 
 menu "Development tools"
        source "package/binutils/Config.in"
-       source "package/bison/Config.in"
        source "package/bsdiff/Config.in"
        source "package/bustle/Config.in"
        source "package/cppunit/Config.in"
diff --git a/package/bison/Config.in b/package/bison/Config.in
deleted file mode 100644 (file)
index 8d88430..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-config BR2_PACKAGE_BISON
-       bool "bison"
-       depends on BR2_USE_WCHAR
-       select BR2_PACKAGE_M4
-       # m4 uses fork()
-       depends on BR2_USE_MMU
-       # development tool, useless on the target
-       depends on BR2_DEPRECATED_SINCE_2014_02
-       help
-         General-purpose parser generator that converts a
-         grammar description for an LALR context-free grammar into a C
-         program to parse that grammar.
-
-         http://www.gnu.org/software/bison/
-
-comment "bison needs a toolchain w/ wchar"
-       depends on BR2_DEPRECATED_SINCE_2014_02
-       depends on BR2_USE_MMU
-       depends on !BR2_USE_WCHAR
index fdf87f62570e5bd969c346f25bc3c3919cfc2cee..c092b7853058478935f52d4bbb91d973a1da2a89 100644 (file)
@@ -9,15 +9,6 @@ BISON_SOURCE = bison-$(BISON_VERSION).tar.xz
 BISON_SITE = $(BR2_GNU_MIRROR)/bison
 BISON_LICENSE = GPLv3+
 BISON_LICENSE_FILES = COPYING
-BISON_CONF_ENV = ac_cv_path_M4=/usr/bin/m4
-BISON_DEPENDENCIES = m4
 BISON_AUTORECONF = YES
 
-define BISON_DISABLE_EXAMPLES
-       echo 'all install:' > $(@D)/examples/Makefile
-endef
-
-BISON_POST_CONFIGURE_HOOKS += BISON_DISABLE_EXAMPLES
-
-$(eval $(autotools-package))
 $(eval $(host-autotools-package))