package/doxygen: disable shared libs for host
authorMichael Nosthoff <buildroot@heine.tech>
Wed, 16 Sep 2020 10:02:09 +0000 (12:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 17 Sep 2020 20:32:09 +0000 (22:32 +0200)
doxygen fails to build with BUILD_SHARED_LIBS=ON as it only
for some targets honors this flag and links the rest static.
So enforce BUILD_SHARED_LIBS=OFF for this package.

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/doxygen/doxygen.mk

index 6d8727208a81f3887650225b07a12846918fccec..ee8ae4fde4d25a5ed77daa6b6a853e3c5f0ca7d3 100644 (file)
@@ -11,4 +11,6 @@ DOXYGEN_LICENSE = GPL-2.0
 DOXYGEN_LICENSE_FILES = LICENSE
 HOST_DOXYGEN_DEPENDENCIES = host-flex host-bison
 
+HOST_DOXYGEN_CONF_OPTS += -DBUILD_SHARED_LIBS=OFF
+
 $(eval $(host-cmake-package))