tinc: disable PIE on ARC
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Mon, 10 Aug 2015 13:36:36 +0000 (16:36 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 10 Aug 2015 13:42:25 +0000 (15:42 +0200)
Even though ARC gcc understands "-pie" option and attempts to generate
PIE binaries as of today PIE is not really supported for user-space
applications.

So we disable PIE detection if building for ARC.
That fixes http://autobuild.buildroot.net/results/2b1/2b1aa474fc432f3f79b03c4577d68642bb7e0f9c
and also prevents execution of non-supported PIE binary in runtime.

[Thomas: fix indentation.]

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tinc/tinc.mk

index b8d4ca77ef22092fa2bbb8fa673ef73e817315f9..f7edd79acd2c07d542771a14c10406839a08fd35 100644 (file)
@@ -11,4 +11,10 @@ TINC_LICENSE = GPLv2+ with OpenSSL exception
 TINC_LICENSE_FILES = COPYING COPYING.README
 TINC_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -std=c99"
 
+ifeq ($(BR2_arc),y)
+TINC_CONF_ENV += \
+       ax_cv_check_cflags___fPIE=no \
+       ax_cv_check_ldflags___pie=no
+endif
+
 $(eval $(autotools-package))