netsnmp: don't list openssl as a hard dependency
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Dec 2008 20:07:50 +0000 (20:07 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Dec 2008 20:07:50 +0000 (20:07 -0000)
netsnmp can be compiled without ssl support, so don't list it as a hard
dependency and only compile in support if enabled by the user.

package/netsnmp/Config.in
package/netsnmp/netsnmp.mk

index 61b460ad61813c34b68e153dbe907ef19cb7cd64..fd54eb40dda4c16d03b99df21bc08d2d025c672a 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_NETSNMP
        bool "netsnmp"
-       select BR2_PACKAGE_OPENSSL
        help
          Suite of applications used to implement SNMP v1, SNMP v2c, and
          SNMP v3 using both IPv4 and IPv6.
index 47ef40f1b4aa17f661212878d4a889582f206b3b..b7b2b140153846212f43919ff6973de061b60acf 100644 (file)
@@ -130,7 +130,7 @@ endif
        $(INSTALL) -D -m 0644 $(NETSNMP_DIR)/agent/mibgroup/header_complex.h $(STAGING_DIR)/usr/include/net-snmp/agent/header_complex.h
        $(INSTALL) -D -m 0755 package/netsnmp/S59snmpd $(TARGET_DIR)/etc/init.d/S59snmpd
 
-netsnmp: openssl $(TARGET_DIR)/usr/sbin/snmpd
+netsnmp: $(if $(BR2_PACKAGE_OPENSSL),openssl) $(TARGET_DIR)/usr/sbin/snmpd
 
 netsnmp-headers: $(TARGET_DIR)/usr/include/net-snmp/net-snmp-config.h
        $(INSTALL) -d $(TARGET_DIR)/usr/include/net-snmp