package/go: set GOCACHE to a host path
authorChristian Stewart <christian@paral.in>
Tue, 12 Mar 2019 05:41:14 +0000 (22:41 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 12 Mar 2019 21:05:57 +0000 (22:05 +0100)
Set the GOCACHE environment variable properly.

It was previously unset, and defaults to $HOME/.cache/go-build.

Signed-off-by: Christian Stewart <christian@paral.in>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/go/go.mk

index 1558b55e215307e0e11c74c049958e00217875cb..4daa2fe093646fc89aa94dfc34f097c7763266d8 100644 (file)
@@ -37,13 +37,16 @@ GO_GOARCH = mips64le
 endif
 
 HOST_GO_DEPENDENCIES = host-go-bootstrap
+HOST_GO_HOST_CACHE = $(HOST_DIR)/usr/share/host-go-cache
 HOST_GO_ROOT = $(HOST_DIR)/lib/go
+HOST_GO_TARGET_CACHE = $(HOST_DIR)/usr/share/go-cache
 
 # For the convienience of target packages.
 HOST_GO_TOOLDIR = $(HOST_GO_ROOT)/pkg/tool/linux_$(GO_GOARCH)
 HOST_GO_TARGET_ENV = \
        GO111MODULE=off \
        GOARCH=$(GO_GOARCH) \
+       GOCACHE="$(HOST_GO_TARGET_CACHE)" \
        GOROOT="$(HOST_GO_ROOT)" \
        CC="$(TARGET_CC)" \
        CXX="$(TARGET_CXX)" \
@@ -63,6 +66,7 @@ endif
 # HOSTCC_NOCCACHE.  See https://github.com/golang/go/issues/11685.
 HOST_GO_MAKE_ENV = \
        GO111MODULE=off \
+       GOCACHE=$(HOST_GO_HOST_CACHE) \
        GOROOT_BOOTSTRAP=$(HOST_GO_BOOTSTRAP_ROOT) \
        GOROOT_FINAL=$(HOST_GO_ROOT) \
        GOROOT="$(@D)" \