package/matchbox: get rid of intermediate non-package matchbox
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Jun 2015 20:41:29 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Jun 2015 21:02:02 +0000 (23:02 +0200)
Currently, the matchbox entry in the menu is a non-package entry, that
forcibly selects the matchbox-wm package, which is the real matchbox WM.

So, get rid of the current matchbox option, rename the existing
matchbox-wm to simply matchbox, so we have a real package from the
onset.

Since we're re-using the previous option for the WM package, there is no
need for an entry in the legacy menu.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/matchbox/0001-defaulttheme.patch [new file with mode: 0644]
package/matchbox/Config.in
package/matchbox/matchbox-wm/0001-defaulttheme.patch [deleted file]
package/matchbox/matchbox-wm/Config.in [deleted file]
package/matchbox/matchbox-wm/matchbox-wm.hash [deleted file]
package/matchbox/matchbox-wm/matchbox-wm.mk [deleted file]
package/matchbox/matchbox.hash [new file with mode: 0644]
package/matchbox/matchbox.mk

diff --git a/package/matchbox/0001-defaulttheme.patch b/package/matchbox/0001-defaulttheme.patch
new file mode 100644 (file)
index 0000000..b4da664
--- /dev/null
@@ -0,0 +1,47 @@
+[PATCH] fix mbtheme build issue when png support is disabled
+
+DEFAULTTHEME{,NAME} is not defined when png support is disabled, leading
+to compile errors in mbtheme.c:
+
+mbtheme.c: In function 'show_parse_error':
+mbtheme.c:2422:28: error: 'DEFAULTTHEME' undeclared (first use in this function)
+mbtheme.c:2422:28: note: each undeclared identifier is reported only once for each function it appears in
+mbtheme.c: In function 'mbtheme_init':
+mbtheme.c:2448:30: error: 'DEFAULTTHEME' undeclared (first use in this function)
+mbtheme.c:2470:25: error: 'DEFAULTTHEMENAME' undeclared (first use in this function)
+
+Fix it by unconditionally defining them as the values used are the same
+in png / !png cases anyway.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ src/structs.h |    9 ---------
+ 1 file changed, 9 deletions(-)
+
+Index: matchbox-window-manager-1.2/src/structs.h
+===================================================================
+--- matchbox-window-manager-1.2.orig/src/structs.h
++++ matchbox-window-manager-1.2/src/structs.h
+@@ -81,8 +81,6 @@
+ #define GENERIC_ICON        PKGDATADIR "/mbnoapp.xpm"
+-#ifdef MB_HAVE_PNG
+-
+ #define DEFAULT_THEME       DATADIR "/themes/Default/matchbox/theme.xml"
+ #define DEFAULTTHEME       DATADIR "/themes/Default/matchbox/theme.xml"
+@@ -91,13 +89,6 @@
+ #define DEFAULTTHEMENAME  "Default"
+-#else
+-
+-#define DEFAULT_THEME       DATADIR "/themes/Default/matchbox/theme.xml"
+-#define DEFAULT_THEME_NAME  "Default"
+-
+-#endif
+-
+ #define CONFDEFAULTS       PKGDATADIR "/defaults"
+ /* Simple Macros  */
index 891ac9583b1ef71b319eb82c802ed4e08be5ee2d..7d06bb29aa450c6712c6c02508484a2ac344c354 100644 (file)
@@ -8,7 +8,6 @@ config BR2_PACKAGE_MATCHBOX
        select BR2_PACKAGE_XLIB_LIBXDAMAGE
        select BR2_PACKAGE_XLIB_LIBXCURSOR
        select BR2_PACKAGE_MATCHBOX_LIB
-       select BR2_PACKAGE_MATCHBOX_WM
        help
          Matchbox is an Open Source base environment for the X Window
          System running on non-desktop embedded platforms such as
@@ -20,7 +19,6 @@ config BR2_PACKAGE_MATCHBOX
 if BR2_PACKAGE_MATCHBOX
 
 source "package/matchbox/matchbox-lib/Config.in"
-source "package/matchbox/matchbox-wm/Config.in"
 source "package/matchbox/matchbox-panel/Config.in"
 source "package/matchbox/matchbox-desktop/Config.in"
 source "package/matchbox/matchbox-common/Config.in"
diff --git a/package/matchbox/matchbox-wm/0001-defaulttheme.patch b/package/matchbox/matchbox-wm/0001-defaulttheme.patch
deleted file mode 100644 (file)
index b4da664..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-[PATCH] fix mbtheme build issue when png support is disabled
-
-DEFAULTTHEME{,NAME} is not defined when png support is disabled, leading
-to compile errors in mbtheme.c:
-
-mbtheme.c: In function 'show_parse_error':
-mbtheme.c:2422:28: error: 'DEFAULTTHEME' undeclared (first use in this function)
-mbtheme.c:2422:28: note: each undeclared identifier is reported only once for each function it appears in
-mbtheme.c: In function 'mbtheme_init':
-mbtheme.c:2448:30: error: 'DEFAULTTHEME' undeclared (first use in this function)
-mbtheme.c:2470:25: error: 'DEFAULTTHEMENAME' undeclared (first use in this function)
-
-Fix it by unconditionally defining them as the values used are the same
-in png / !png cases anyway.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- src/structs.h |    9 ---------
- 1 file changed, 9 deletions(-)
-
-Index: matchbox-window-manager-1.2/src/structs.h
-===================================================================
---- matchbox-window-manager-1.2.orig/src/structs.h
-+++ matchbox-window-manager-1.2/src/structs.h
-@@ -81,8 +81,6 @@
- #define GENERIC_ICON        PKGDATADIR "/mbnoapp.xpm"
--#ifdef MB_HAVE_PNG
--
- #define DEFAULT_THEME       DATADIR "/themes/Default/matchbox/theme.xml"
- #define DEFAULTTHEME       DATADIR "/themes/Default/matchbox/theme.xml"
-@@ -91,13 +89,6 @@
- #define DEFAULTTHEMENAME  "Default"
--#else
--
--#define DEFAULT_THEME       DATADIR "/themes/Default/matchbox/theme.xml"
--#define DEFAULT_THEME_NAME  "Default"
--
--#endif
--
- #define CONFDEFAULTS       PKGDATADIR "/defaults"
- /* Simple Macros  */
diff --git a/package/matchbox/matchbox-wm/Config.in b/package/matchbox/matchbox-wm/Config.in
deleted file mode 100644 (file)
index 6ad5dfc..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-config BR2_PACKAGE_MATCHBOX_WM
-       bool
-       select BR2_PACKAGE_MATCHBOX_LIB
diff --git a/package/matchbox/matchbox-wm/matchbox-wm.hash b/package/matchbox/matchbox-wm/matchbox-wm.hash
deleted file mode 100644 (file)
index f00ed4e..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# From http://downloads.yoctoproject.org/releases/matchbox/matchbox-window-manager/1.2/matchbox-window-manager-1.2.tar.bz2.md5
-md5    3e158dcf57823b55c926d95b245500fb        matchbox-window-manager-1.2.tar.bz2
diff --git a/package/matchbox/matchbox-wm/matchbox-wm.mk b/package/matchbox/matchbox-wm/matchbox-wm.mk
deleted file mode 100644 (file)
index da9efd7..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-################################################################################
-#
-# matchbox-wm
-#
-################################################################################
-
-MATCHBOX_WM_VERSION = 1.2
-MATCHBOX_WM_SOURCE = matchbox-window-manager-$(MATCHBOX_WM_VERSION).tar.bz2
-MATCHBOX_WM_SITE = http://downloads.yoctoproject.org/releases/matchbox/matchbox-window-manager/$(MATCHBOX_WM_VERSION)
-MATCHBOX_WM_LICENSE = GPLv2+
-MATCHBOX_WM_LICENSE_FILES = COPYING
-
-MATCHBOX_WM_DEPENDENCIES = matchbox-lib
-MATCHBOX_WM_CONF_OPTS = --enable-expat
-
-# Workaround bug in configure script
-MATCHBOX_WM_CONF_ENV = expat=yes
-
-ifeq ($(BR2_PACKAGE_X11R7_LIBXCOMPOSITE),y)
-ifeq ($(BR2_PACKAGE_X11R7_LIBXPM),y)
-MATCHBOX_WM_CONF_OPTS += --enable-composite
-MATCHBOX_WM_DEPENDENCIES += xlib_libXcomposite
-MATCHBOX_WM_DEPENDENCIES += xlib_libXpm
-endif
-endif
-
-ifeq ($(BR2_PACKAGE_XLIB_LIBXFT),y)
-MATCHBOX_WM_DEPENDENCIES += xlib_libXft
-endif
-
-ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
-MATCHBOX_WM_CONF_OPTS += --enable-startup-notification
-MATCHBOX_WM_DEPENDENCIES += startup-notification
-else
-MATCHBOX_WM_CONF_OPTS += --disable-startup-notification
-endif
-
-$(eval $(autotools-package))
diff --git a/package/matchbox/matchbox.hash b/package/matchbox/matchbox.hash
new file mode 100644 (file)
index 0000000..f00ed4e
--- /dev/null
@@ -0,0 +1,2 @@
+# From http://downloads.yoctoproject.org/releases/matchbox/matchbox-window-manager/1.2/matchbox-window-manager-1.2.tar.bz2.md5
+md5    3e158dcf57823b55c926d95b245500fb        matchbox-window-manager-1.2.tar.bz2
index ae989b3941307b66dfa43216eec0103339a3a99e..100a633363c67e8f93e677b3845c30af6202438c 100644 (file)
@@ -1 +1,41 @@
+################################################################################
+#
+# matchbox
+#
+################################################################################
+
+MATCHBOX_VERSION = 1.2
+MATCHBOX_SOURCE = matchbox-window-manager-$(MATCHBOX_VERSION).tar.bz2
+MATCHBOX_SITE = http://downloads.yoctoproject.org/releases/matchbox/matchbox-window-manager/$(MATCHBOX_VERSION)
+MATCHBOX_LICENSE = GPLv2+
+MATCHBOX_LICENSE_FILES = COPYING
+
+MATCHBOX_DEPENDENCIES = matchbox-lib
+MATCHBOX_CONF_OPTS = --enable-expat
+
+# Workaround bug in configure script
+MATCHBOX_CONF_ENV = expat=yes
+
+ifeq ($(BR2_PACKAGE_X11R7_LIBXCOMPOSITE),y)
+ifeq ($(BR2_PACKAGE_X11R7_LIBXPM),y)
+MATCHBOX_CONF_OPTS += --enable-composite
+MATCHBOX_DEPENDENCIES += xlib_libXcomposite
+MATCHBOX_DEPENDENCIES += xlib_libXpm
+endif
+endif
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXFT),y)
+MATCHBOX_DEPENDENCIES += xlib_libXft
+endif
+
+ifeq ($(BR2_PACKAGE_STARTUP_NOTIFICATION),y)
+MATCHBOX_CONF_OPTS += --enable-startup-notification
+MATCHBOX_DEPENDENCIES += startup-notification
+else
+MATCHBOX_CONF_OPTS += --disable-startup-notification
+endif
+
+$(eval $(autotools-package))
+
+# After we called a package infra, we can include more files
 include $(sort $(wildcard package/matchbox/*/*.mk))