package/libgee: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:31 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:39 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libgee/libgee.mk

index 81fd354fe84b668ece35cbe0fe7b3465822526e3..4b2581e1717fd053af13eb1cbddd0922f09eec73 100644 (file)
@@ -13,4 +13,11 @@ LIBGEE_INSTALL_STAGING = YES
 LIBGEE_LICENSE = LGPL-2.1+
 LIBGEE_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBGEE_CONF_OPTS += --enable-introspection
+LIBGEE_DEPENDENCIES += gobject-introspection
+else
+LIBGEE_CONF_OPTS += --disable-introspection
+endif
+
 $(eval $(autotools-package))