gtest: generate the gtest-config script
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Apr 2015 09:22:42 +0000 (11:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Apr 2015 09:22:42 +0000 (11:22 +0200)
gtest has moved from the autotools to CMake, but the CMake build
system is currently not installing the gtest-config script. Work
around that by installing it manually, after doing the necessary
sed-ing from the gtest-config.in template.

Reported-by: Carlos Santos <casantos@datacom.ind.br>
Suggested-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gtest/gtest.mk

index 7129c939d35753743e8c8407a777a17720564cf1..562acf015e54313a351408abcb0a6985a4d8a4a6 100644 (file)
@@ -30,6 +30,20 @@ define GTEST_INSTALL_STAGING_CMDS
        $(INSTALL) -D -m 0755 $(@D)/libgtest_main.a $(STAGING_DIR)/usr/lib/libgtest_main.a
        $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include/gtest/
        cp -rp $(@D)/include/gtest/* $(STAGING_DIR)/usr/include/gtest/
+       # Generate the gtest-config script manually, since the CMake
+       # build system is not doing it.
+       sed 's%@PACKAGE_TARNAME@%gtest%;\
+               s%@PACKAGE_VERSION@%$(GTEST_VERSION)%;\
+               s%@prefix@%$(STAGING_DIR)/usr%;\
+               s%@exec_prefix@%$(STAGING_DIR)/usr%;\
+               s%@libdir@%$(STAGING_DIR)/usr/lib%;\
+               s%@includedir@%$(STAGING_DIR)/usr/include%;\
+               s%@bindir@%$(STAGING_DIR)/usr/bin%;\
+               s%@PTHREAD_CFLAGS@%%;\
+               s%@PTHREAD_LIBS@%-lpthread%;' \
+               $(@D)/scripts/gtest-config.in \
+               > $(STAGING_DIR)/usr/bin/gtest-config
+       chmod +x $(STAGING_DIR)/usr/bin/gtest-config
 endef
 
 $(eval $(cmake-package))