linux: Do not force GZIP initramfs compression
authorValentine Barshak <gvaxon@gmail.com>
Tue, 9 Oct 2012 23:34:56 +0000 (03:34 +0400)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 8 Jul 2013 12:50:31 +0000 (14:50 +0200)
Initramfs compression does not make much sense for the architectures
that support compressed kernel images because in this case the data
would be compressed twice. This will eventually result in a bigger
kernel image and time overhead when uncompressing it.
The only reason to use compressed initramfs is to reduce memory
usage when the kernel prepares rootfs, and both the unpacked
filesystem and initramfs.cpio are present in the memory.

Buildroot attempts to force GZIP compression for initramfs,
however it doesn't always work because initramfs compression mode
depends on RAM disk compression supported by the kernel.
Thus, CONFIG_INITRAMFS_COMPRESSION_GZIP depends on CONFIG_RD_GZIP.
If CONFIG_RD_GZIP is not set, setting GZIP initramfs compression
will have no effect.

Besides, the kernel also supports other compression methods,
like BZIP2, LZMA, XZ and LZO. Forcing the good old GZIP does not
really make much sense any more.

This removes initramfs compression settings from Buildroot,
so that the default value preset in the kernel config is used,
which is CONFIG_INITRAMFS_COMPRESSION_NONE.

If initramfs compression is still needed, it can be set
in the kernel config (using make linux-menuconfig)

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/initramfs/Config.in
linux/linux.mk

index 22066eef9615e1055bd02ce143d72c2d4a6d3208..ac450305121eb6a10fa291d063ae4fdb7dd1657b 100644 (file)
@@ -9,8 +9,8 @@ config BR2_TARGET_ROOTFS_INITRAMFS
 
          A rootfs.cpio file will be generated in the images/ directory.
          This is the archive that will be included in the kernel image.
-         The rootfs in the kernel will always be gzip'ed, regardless
-         of how buildroot's cpio archive is configured.
+         The default rootfs compression set in the kernel configuration
+         is used, regardless of how buildroot's cpio archive is configured.
 
          Note that enabling initramfs together with another filesystem
          formats doesn't make sense: you would end up having two
index befef1658b30f960995d89a5da15858e58876951..dfc948ca515ba1cf843bcbef582e87580cdbdaa7 100644 (file)
@@ -182,9 +182,7 @@ define LINUX_CONFIGURE_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_INITRD,$(@D)/.config)
                $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_SOURCE,\"$(BINARIES_DIR)/rootfs.cpio\",$(@D)/.config)
                $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_UID,0,$(@D)/.config)
-               $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0,$(@D)/.config)
-               $(call KCONFIG_DISABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_NONE,$(@D)/.config)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_INITRAMFS_COMPRESSION_GZIP,$(@D)/.config))
+               $(call KCONFIG_SET_OPT,CONFIG_INITRAMFS_ROOT_GID,0,$(@D)/.config))
        $(if $(BR2_ROOTFS_DEVICE_CREATION_STATIC),,
                $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_DEVTMPFS_MOUNT,$(@D)/.config))