package/libglib2: fix util-linux-libs dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Nov 2020 12:15:36 +0000 (13:15 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 1 Nov 2020 13:05:27 +0000 (14:05 +0100)
Commit 2acaa86ce630f616b12aa92493e0269421c5bc97 replaced util-linux by
util-linux-libs but this raises the following build failure:

Makefile:585: *** util-linux-libs is in the dependency chain of libglib2 that has added it to its _DEPENDENCIES variable without selecting it or depending on it from Config.in.  Stop.

To fix this build failure, use util-linux or util-linux-libs depending
on BR2_PACKAGE_UTIL_LINUX_LIBS

Fixes:
 - http://autobuild.buildroot.org/results/8bf6360a343edd10c73a756ab86cdba727f9ea43

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libglib2/libglib2.mk

index 43fcb27faea70d1196c023d5a8f2c93f4430f4bd..6e9dbd7b2638aa9020ef6fde14ef2071aad62716 100644 (file)
@@ -86,8 +86,12 @@ endif
 
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBMOUNT),y)
 LIBGLIB2_CONF_OPTS += -Dlibmount=enabled
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBS),y)
 LIBGLIB2_DEPENDENCIES += util-linux-libs
 else
+LIBGLIB2_DEPENDENCIES += util-linux
+endif
+else
 LIBGLIB2_CONF_OPTS += -Dlibmount=disabled
 endif