package/mesa3d: add support for gallium tegra driver
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 28 Sep 2019 06:38:56 +0000 (08:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Sep 2019 19:57:00 +0000 (21:57 +0200)
"tegra driver requires nouveau driver":
https://cgit.freedesktop.org/mesa/mesa/tree/meson.build?h=19.2#n251

Suggested-by: Ross Green <grunpferd@netscape.net>
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mesa3d/Config.in
package/mesa3d/mesa3d.mk

index 92caa05679218ca3f704bfbe394f2724eb1923e8..d9a705f99188663f51c28d36f98eaf24c8a17b71 100644 (file)
@@ -194,6 +194,15 @@ config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SWRAST
 comment "Gallium swrast: Only one swrast provider can be built"
        depends on BR2_PACKAGE_MESA3D_DRI_DRIVER_SWRAST
 
+config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_TEGRA
+       bool "Gallium tegra driver"
+       select BR2_PACKAGE_MESA3D_GALLIUM_DRIVER
+       select BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_NOUVEAU
+       select BR2_PACKAGE_LIBDRM_NOUVEAU
+       select BR2_PACKAGE_MESA3D_NEEDS_XA
+       help
+         Adds support for Nvidia Tegra GPUs, requires nouveau.
+
 config BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_VC4
        bool "Gallium vc4 driver"
        depends on BR2_arm || BR2_aarch64
index 82781c9e10499e11016df436ae6680b04102a7ca..b47c6b9b2e7b2806340d7efb280e287588c1b761 100644 (file)
@@ -93,6 +93,7 @@ MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_R600)     += r600
 MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_RADEONSI) += radeonsi
 MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SVGA)     += svga
 MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_SWRAST)   += swrast
+MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_TEGRA)    += tegra
 MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_VC4)      += vc4
 MESA3D_GALLIUM_DRIVERS-$(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_VIRGL)    += virgl
 # DRI Drivers