Revert "package/php: fix building pcre extension"
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 16 Jan 2019 21:00:15 +0000 (22:00 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 19 Jan 2019 21:33:43 +0000 (22:33 +0100)
This reverts commit 745f884e41b5f350296e8448f5fc31d20f67a077.

This was the wrong fix: issue is that php moves from pcre to pcre2 since
version 7.3.0 and
http://github.com/php/php-src/commit/a5bc5aed71f7a15f14f33bb31b8e17bf5f327e2d

This patch will always disable external pcre2 support and raise a build
failure when toolchaine does not have pthread

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/php/php.mk

index 7d7d78353bc95a97f3cd168993313121f77eb7ca..fd428e192a4a4537bf58dbbce797e79b1b1244b7 100644 (file)
@@ -244,7 +244,7 @@ PHP_POST_CONFIGURE_HOOKS += PHP_DISABLE_VALGRIND
 
 ### Use external PCRE if it's available
 ifeq ($(BR2_PACKAGE_PCRE),y)
-PHP_CONF_OPTS += --with-pcre-regex
+PHP_CONF_OPTS += --with-pcre-regex=$(STAGING_DIR)/usr
 PHP_DEPENDENCIES += pcre
 else
 # The bundled pcre library is not configurable through ./configure options,