qemu: enable seccomp if libseccomp is selected
authorCarlos Santos <casantos@datacom.com.br>
Sun, 25 Nov 2018 01:21:22 +0000 (23:21 -0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 25 Nov 2018 08:14:51 +0000 (09:14 +0100)
It is required to use qemu with libvirt and allows us to resume working
on the libvirt package (https://patchwork.ozlabs.org/patch/841613).

Signed-off-by: Carlos Santos <casantos@datacom.com.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/qemu.mk

index 5ee6abf7316d01b5cb7fcf7ae1475c40d3704ce1..66b74467b907f4c8b0926349ac0ee326162efab4 100644 (file)
@@ -81,6 +81,13 @@ else
 QEMU_OPTS += --disable-tools
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
+QEMU_OPTS += --enable-seccomp
+QEMU_DEPENDENCIES += libseccomp
+else
+QEMU_OPTS += --disable-seccomp
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSSH2),y)
 QEMU_OPTS += --enable-libssh2
 QEMU_DEPENDENCIES += libssh2
@@ -121,7 +128,6 @@ define QEMU_CONFIGURE_CMDS
                        --disable-libiscsi \
                        --disable-usb-redir \
                        --disable-strip \
-                       --disable-seccomp \
                        --disable-sparse \
                        --disable-mpath \
                        --disable-sanitizers \