package: add dbus-python
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Mar 2009 11:27:49 +0000 (11:27 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Mar 2009 11:27:49 +0000 (11:27 -0000)
package/Config.in
package/dbus-python/Config.in [new file with mode: 0644]
package/dbus-python/dbus-python-fix-python-configure-check.patch [new file with mode: 0644]
package/dbus-python/dbus-python.mk [new file with mode: 0644]

index 07d72c0506f371a41cbbb8f046a7aa5fa440adbe..9b311675c4330d67f4e9f36ed90e08702b924eea 100644 (file)
@@ -226,6 +226,7 @@ menu "Hardware handling / blockdevices and filesystem maintenance"
 source "package/acpid/Config.in"
 source "package/dbus/Config.in"
 source "package/dbus-glib/Config.in"
+source "package/dbus-python/Config.in"
 source "package/devmem2/Config.in"
 source "package/dm/Config.in"
 source "package/dmraid/Config.in"
diff --git a/package/dbus-python/Config.in b/package/dbus-python/Config.in
new file mode 100644 (file)
index 0000000..f5705a5
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_DBUS_PYTHON
+       bool "dbus-python"
+       depends on BR2_PACKAGE_DBUS
+       depends on BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_DBUS_GLIB
+       help
+         Python bindings for D-Bus
+
+         http://dbus.freedesktop.org/doc/dbus-python/
diff --git a/package/dbus-python/dbus-python-fix-python-configure-check.patch b/package/dbus-python/dbus-python-fix-python-configure-check.patch
new file mode 100644 (file)
index 0000000..30eeb48
--- /dev/null
@@ -0,0 +1,30 @@
+Python: add am_cv_python_includes to override runtime python-config check
+---
+ configure |    7 +++++++
+ 1 file changed, 7 insertions(+)
+
+Index: dbus-python-0.83.0/configure
+===================================================================
+--- dbus-python-0.83.0.orig/configure
++++ dbus-python-0.83.0/configure
+@@ -10176,6 +10176,12 @@
+ { echo "$as_me:$LINENO: checking for Python headers using $PYTHON-config --includes" >&5
+ echo $ECHO_N "checking for Python headers using $PYTHON-config --includes... $ECHO_C" >&6; }
++if test "${am_cv_python_includes+set}" = set; then
++  echo $ECHO_N "(cached) $ECHO_C" >&6
++  PYTHON_INCLUDES=${am_cv_python_includes}
++  { echo "$as_me:$LINENO: result: $PYTHON_INCLUDES" >&5
++echo "${ECHO_T}$PYTHON_INCLUDES" >&6; }
++else
+ PYTHON_INCLUDES=`$PYTHON-config --includes`
+ if test $? = 0; then
+   { echo "$as_me:$LINENO: result: $PYTHON_INCLUDES" >&5
+@@ -10194,6 +10200,7 @@
+   { echo "$as_me:$LINENO: result: $PYTHON_INCLUDES" >&5
+ echo "${ECHO_T}$PYTHON_INCLUDES" >&6; }
+ fi
++fi
+ { echo "$as_me:$LINENO: checking whether those headers are sufficient" >&5
+ echo $ECHO_N "checking whether those headers are sufficient... $ECHO_C" >&6; }
diff --git a/package/dbus-python/dbus-python.mk b/package/dbus-python/dbus-python.mk
new file mode 100644 (file)
index 0000000..5100fec
--- /dev/null
@@ -0,0 +1,24 @@
+#############################################################
+#
+# dbus-python
+#
+#############################################################
+DBUS_PYTHON_VERSION = 0.83.0
+DBUS_PYTHON_SOURCE = dbus-python-$(DBUS_PYTHON_VERSION).tar.gz
+DBUS_PYTHON_SITE = http://dbus.freedesktop.org/releases/dbus-python/
+DBUS_PYTHON_INSTALL_STAGING = YES
+DBUS_PYTHON_INSTALL_TARGET = YES
+
+DBUS_PYTHON_CONF_ENV = am_cv_pathless_PYTHON=python \
+               ac_cv_path_PYTHON=$(PYTHON_DIR)/hostpython \
+               am_cv_python_version=$(PYTHON_VERSION) \
+               am_cv_python_platform=linux2 \
+               am_cv_python_pythondir=/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages \
+               am_cv_python_pyexecdir=/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages \
+               am_cv_python_includes=-I$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
+
+DBUS_PYTHON_CONF_OPT = --disable-html-docs --disable-api-docs
+
+DBUS_PYTHON_DEPENDENCIES = uclibc dbus-glib libpython
+
+$(eval $(call AUTOTARGETS,package,dbus-python))