projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
31aa331
)
fs/squashfs: fix image file permissions
author
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 31 Aug 2010 19:53:40 +0000
(21:53 +0200)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 31 Aug 2010 19:53:40 +0000
(21:53 +0200)
Set image file permissions to 0644 like it was before the fs rework,
instead of the rather unhelpful 0700 (E.G. when image is used for tftp).
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/squashfs/squashfs.mk
patch
|
blob
|
history
diff --git
a/fs/squashfs/squashfs.mk
b/fs/squashfs/squashfs.mk
index 6117de62a18d57c58fde71f6076834f137bba970..aae22b6fdda8e26f6db5f8542af2a264804176c9 100644
(file)
--- a/
fs/squashfs/squashfs.mk
+++ b/
fs/squashfs/squashfs.mk
@@
-19,7
+19,8
@@
endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend \
- $(ROOTFS_SQUASHFS_ARGS)
+ $(ROOTFS_SQUASHFS_ARGS) && \
+ chmod 0644 $$@
endef
$(eval $(call ROOTFS_TARGET,squashfs))