rsyslog: add optional gnutls support
authorAdrien Decostre <ad.decostre@gmail.com>
Wed, 15 Jun 2016 13:17:48 +0000 (15:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Jun 2016 13:11:59 +0000 (15:11 +0200)
[Peter: drop explicit option and handle like other dependencies]
Signed-off-by: Adrien Decostre <ad.decostre@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsyslog/rsyslog.mk

index 40e3b338250a71760824deb2f2c99a2ce629f73f..18a57372fdfe431af160ea16fde538c4d235579c 100644 (file)
@@ -22,6 +22,13 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 RSYSLOG_DEPENDENCIES += busybox
 endif
 
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+RSYSLOG_DEPENDENCIES += gnutls
+RSYSLOG_CONF_OPTS += --enable-gnutls
+else
+RSYSLOG_CONF_OPTS += --disable-gnutls
+endif
+
 ifeq ($(BR2_PACKAGE_LIBEE),y)
 RSYSLOG_DEPENDENCIES += libee
 endif