dbus: revert to pre-r25021 situation
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 31 Jan 2009 18:39:55 +0000 (18:39 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 31 Jan 2009 18:39:55 +0000 (18:39 -0000)
Revert to pre-r25021 situation, but add extra comments explaining the
situation.

package/dbus/dbus.mk

index 8f1ac6d17d8ae25daa421fbe2c6fbf47267f08b8..92405bd5bd8cf5aaf9efe01795106dcd71f131de 100644 (file)
@@ -13,10 +13,18 @@ DBUS_TARGET_BINARY:=usr/bin/dbus-daemon
 
 ifeq ($(BR2_DBUS_EXPAT),y)
 DBUS_XML:=expat
-DBUS_XML_DEP:=expat
+# depend on the exact library file instead of expat so dbus isn't always
+# considered out-of-date
+DBUS_XML_DEP:=$(STAGING_DIR)/usr/lib/libexpat.so.1
 else
 DBUS_XML:=libxml
-DBUS_XML_DEP:=libxml2
+# Makefile.autotools.in unfortunately has broken dependency handling,
+# so we cannot do the same for libxml2 as the targets (like
+# libxml2-install-staging) are phony and hence, dbus will always be
+# considered out-of-date. Using the corresponding .stamp_* files (E.G.
+# LIBXML2_TARGET_INSTALL_STAGING doesn't work as there's no dependency
+# information between them.
+DBUS_XML_DEP:=libxml2-install-staging
 endif
 
 $(DL_DIR)/$(DBUS_SOURCE):
@@ -86,7 +94,7 @@ ifneq ($(BR2_HAVE_MANPAGES),y)
        rm -rf $(TARGET_DIR)/usr/share/man
 endif
 
-dbus: uclibc pkgconfig $(DBUS_XML_DEP) $(TARGET_DIR)/$(DBUS_TARGET_BINARY)
+dbus: uclibc pkgconfig $(TARGET_DIR)/$(DBUS_TARGET_BINARY)
 
 dbus-clean:
        rm -f $(TARGET_DIR)/etc/dbus-1/session.conf
@@ -113,9 +121,3 @@ dbus-dirclean:
 ifeq ($(BR2_PACKAGE_DBUS),y)
 TARGETS+=dbus
 endif
-
-dbus-status:
-       @echo   BR2_DBUS_EXPAT=$(BR2_DBUS_EXPAT)
-       @echo   DBUS_XML=$(DBUS_XML)
-       @echo   DBUS_XML_DEP=$(DBUS_XML_DEP)
-