i2c-tools: install library and header to staging
authorBrad Love <brad@nextdimension.cc>
Fri, 24 Aug 2018 13:54:07 +0000 (08:54 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 Aug 2018 21:58:24 +0000 (23:58 +0200)
When the dynamic/static library of i2c-tools is enabled it is installed
to the target destination. However, in order for external packages to
link against it, it must also be installed to staging.

Here, the flag is set to install the package to staging. The
INSTALL_STAGING command is included to complete the operation.

Signed-off-by: Brad Love <brad@nextdimension.cc>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/i2c-tools/i2c-tools.mk

index ec06c7332599174e9186383d67bf80e2e18ed225..11d0cf9808197cc8a1a77799dd4f430f1558f8af 100644 (file)
@@ -10,6 +10,7 @@ I2C_TOOLS_SITE = https://www.kernel.org/pub/software/utils/i2c-tools
 I2C_TOOLS_LICENSE = GPL-2.0+, GPL-2.0 (py-smbus), LGPL-2.1+ (libi2c)
 I2C_TOOLS_LICENSE_FILES = COPYING COPYING.LGPL README
 I2C_TOOLS_MAKE_OPTS = EXTRA=eeprog
+I2C_TOOLS_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 I2C_TOOLS_DEPENDENCIES += python
@@ -62,4 +63,9 @@ define I2C_TOOLS_INSTALL_TARGET_CMDS
        $(I2C_TOOLS_INSTALL_PYSMBUS)
 endef
 
+define I2C_TOOLS_INSTALL_STAGING_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) $(I2C_TOOLS_MAKE_OPTS) \
+               DESTDIR="$(STAGING_DIR)" prefix=/usr -C $(@D) install
+endef
+
 $(eval $(generic-package))