vlc: avoid that AUTORECONF renames configure's arguments
authorArnout Vandecappelle <arnout@mind.be>
Thu, 27 Feb 2014 19:37:34 +0000 (20:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 13:53:19 +0000 (14:53 +0100)
VLC defines two autoconf functions which are also defined by our own
pkg.m4 from pkgconf. Unfortunately, they are defined in a different way:
VLC adds --enable- options, but pkg.m4 adds --with- options. To make
sure we use VLC's definition, rename these two functions from
PKG_WITH_MODULES to VLC_PKG_WITH_MODULES and from PKG_HAVE_WITH_MODULES
to VLC_PKG_HAVE_WITH_MODULES.

Note that the second function (PKG_HAVE_WITH_MODULES) is in fact
defined in exactly the same way by VLC and pkgconf, but this might no
longer be the case when either pkgconf or VLC is updated. Therefore,
that one is renamed as well.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Simon Dawson <spdawson@gmail.com>
Tested-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index e25f2d22ad7c625aa3a674f8dca99f04ccddf59a..e6d0dedd934f59301c105c705323af1e32a492d9 100644 (file)
@@ -12,6 +12,17 @@ VLC_LICENSE_FILES = COPYING COPYING.LIB
 VLC_DEPENDENCIES = host-pkgconf
 VLC_AUTORECONF = YES
 
+# VLC defines two autoconf functions which are also defined by our own pkg.m4
+# from pkgconf. Unfortunately, they are defined in a different way: VLC adds
+# --enable- options, but pkg.m4 adds --with- options. To make sure we use
+# VLC's definition, rename these two functions.
+define VLC_OVERRIDE_PKG_M4
+       $(SED) 's/PKG_WITH_MODULES/VLC_PKG_WITH_MODULES/g' \
+               -e 's/PKG_HAVE_WITH_MODULES/VLC_PKG_HAVE_WITH_MODULES/g' \
+               $(@D)/configure.ac $(@D)/m4/with_pkg.m4
+endef
+VLC_POST_PATCH_HOOKS += VLC_OVERRIDE_PKG_M4
+
 VLC_CONF_OPT += \
        --disable-a52 \
        --disable-shout \