Revert "package/cracklib: add python3 support"
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 19 May 2020 19:08:11 +0000 (21:08 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 19 May 2020 19:08:11 +0000 (21:08 +0200)
This reverts commit f584595424137399dd06f73c6f04c759e04b879e.
It in fact depends on a previous patch to python that was not applied
[0], as upstream believes it is dangerous [1], and is still debating the
proper solution [2].

[0] https://patchwork.ozlabs.org/project/buildroot/patch/20200202205306.1785085-1-fontaine.fabrice@gmail.com/
[1] https://bugs.python.org/issue39026#msg369309
[2] https://bugs.python.org/issue39026

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/cracklib/cracklib.mk

index be1b50f1387b8bda0f9e4a50fdb44c943fb49f31..91d510ff3423570d88219c3f5fadb66817641c4a 100644 (file)
@@ -19,9 +19,9 @@ else
 CRACKLIB_CONF_OPTS += --without-zlib
 endif
 
-ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
+ifeq ($(BR2_PACKAGE_PYTHON),y)
 CRACKLIB_CONF_OPTS += --with-python
-CRACKLIB_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
+CRACKLIB_DEPENDENCIES += python
 else
 CRACKLIB_CONF_OPTS += --without-python
 endif