linux: use the generic help rules
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 4 Jun 2016 16:30:51 +0000 (18:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Jun 2016 20:10:20 +0000 (22:10 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Thomas: don't use the helper.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
linux/linux.mk

index f5ae613a554a49e97ed08ce7f4ab18b7853da87e..bb3d5880887ce823fd2b066de36f60e47dff0e53 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -941,12 +941,6 @@ help:
                @echo $(sep) \
                @echo '$($(p)_NAME):' $(sep) \
                $($(p)_HELP_CMDS)$(sep))
-ifeq ($(BR2_LINUX_KERNEL),y)
-       @echo '  linux-menuconfig       - Run Linux kernel menuconfig'
-       @echo '  linux-savedefconfig    - Run Linux kernel savedefconfig'
-       @echo '  linux-update-defconfig - Save the Linux configuration to the path specified'
-       @echo '                             by BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE'
-endif
 ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
        @echo '  uclibc-menuconfig      - Run uClibc menuconfig'
 endif
index 4f4f80239ee23f02bb48734a1da58a0aa0622598..fdd8421d948e54568705ae0e834b2680bd41ebc7 100644 (file)
@@ -8,6 +8,13 @@ LINUX_VERSION = $(call qstrip,$(BR2_LINUX_KERNEL_VERSION))
 LINUX_LICENSE = GPLv2
 LINUX_LICENSE_FILES = COPYING
 
+define LINUX_HELP_CMDS
+       @echo '  linux-menuconfig       - Run Linux kernel menuconfig'
+       @echo '  linux-savedefconfig    - Run Linux kernel savedefconfig'
+       @echo '  linux-update-defconfig - Save the Linux configuration to the path specified'
+       @echo '                             by BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE'
+endef
+
 # Compute LINUX_SOURCE and LINUX_SITE from the configuration
 ifeq ($(BR2_LINUX_KERNEL_CUSTOM_TARBALL),y)
 LINUX_TARBALL = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION))