squid: add optional dependency on libkrb5
authorAndré Hentschel <nerv@dawncrow.de>
Wed, 7 Mar 2018 20:15:58 +0000 (21:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 31 Mar 2018 14:13:39 +0000 (16:13 +0200)
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/squid/squid.mk

index 8ade55ee37e99788245ca3a85611643afd7c943f..2d21ad8858d4924e551f805e1535e5189f5df40a 100644 (file)
@@ -29,7 +29,6 @@ SQUID_CONF_OPTS = \
        --enable-removal-policies="lru,heap" \
        --with-filedescriptors=1024 \
        --disable-ident-lookups \
-       --without-mit-krb5 \
        --enable-auth-basic="fake getpwnam" \
        --enable-auth-digest="file" \
        --enable-auth-negotiate="wrapper" \
@@ -50,6 +49,13 @@ else
 SQUID_CONF_ENV += squid_cv_gnu_atomics=no
 endif
 
+ifeq ($(BR2_PACKAGE_LIBKRB5),y)
+SQUID_CONF_OPTS += --with-mit-krb5
+SQUID_DEPENDENCIES += libkrb5
+else
+SQUID_CONF_OPTS += --without-mit-krb5
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 SQUID_CONF_OPTS += --with-openssl
 SQUID_DEPENDENCIES += openssl