package/brotli: work around gcc bug 68485
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Mon, 27 May 2019 21:38:23 +0000 (23:38 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 27 May 2019 22:09:03 +0000 (00:09 +0200)
With Microblaze Gcc version <= 9.x the build fails due to gcc bug 68485:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. The bug show up when
building brotli with optimization but not when building with -O0. To
work around this, if BR2_TOOLCHAIN_HAS_GCC_BUG_68458=y, we force using
-O0.

Fixes:

  http://autobuild.buildroot.net/results/d86/d86251974a0a348a64d9a1d1fd7d02dd4aff0792/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/brotli/brotli.mk

index 2c1ad4875343aa47e0f3fe0aba94701fc47c52e9..248bfb9daf858ff91ba055f6679ef505f9fcfbc3 100644 (file)
@@ -14,4 +14,8 @@ BROTLI_CONF_OPTS = \
        -DBROTLI_DISABLE_TESTS=ON \
        -DBROTLI_BUNDLED_MODE=OFF
 
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
+BROTLI_CONF_OPTS += -DCMAKE_C_FLAGS="-O0"
+endif
+
 $(eval $(cmake-package))