Be extra sure that /etc/init.d/S30pcmcia is executable
authorEric Andersen <andersen@codepoet.org>
Tue, 4 Feb 2003 10:35:13 +0000 (10:35 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 4 Feb 2003 10:35:13 +0000 (10:35 -0000)
make/pcmcia.mk

index 51f634df3ca8906e25f8955d65724a5a21453368..b81275f38f227d949fbdaf1d200c2bc42b123596 100644 (file)
@@ -79,6 +79,7 @@ $(TARGET_DIR)/sbin/cardmgr: $(PCMCIA_DIR)/cardmgr/cardmgr
        rm -f $(TARGET_DIR)/sbin/pcinitrd
        rm -f $(TARGET_DIR)/sbin/probe
        cp $(PCMCIA_DIR)/etc/rc.pcmcia $(TARGET_DIR)/etc/init.d/S30pcmcia
+       chmod a+x $(TARGET_DIR)/etc/init.d/S30pcmcia
        chmod -R u+w $(TARGET_DIR)/etc/pcmcia/*
 
 pcmcia: uclibc $(TARGET_DIR)/sbin/cardmgr