package/proftpd: add enable buffer size
authorJared Bents <jared.bents@rockwellcollins.com>
Mon, 12 Nov 2018 16:45:20 +0000 (10:45 -0600)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 14 Nov 2018 08:18:40 +0000 (09:18 +0100)
Enable buffer size as a compile time option to change internal
buffer size.

Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/proftpd/Config.in
package/proftpd/proftpd.mk

index b615a5ff4c97b93cd53d55830a8673d06fbf730c..478a7e80e1366713b49520a50b9a88d6db9ba577 100644 (file)
@@ -65,4 +65,17 @@ config BR2_PACKAGE_PROFTPD_MOD_QUOTATAB_SQL
          Compile mod_quotatab with mod_quotatab_sql table.
 
 endif
+
+config BR2_PACKAGE_PROFTPD_BUFFER_SIZE
+       int "buffer size in bytes (0 for default)"
+       default "0"
+       help
+         By increasing the buffer size above the default of 1K,
+         proftpd reads and writes data in larger chunks, and makes
+         fewer expensive system calls. Use of this option to set buffer
+         sizes of 8K or more has been reported to drastically increase
+         transfer speeds (depending on network configurations).
+
+         0 uses the default size of 1024.
+
 endif
index 8f3ff5088e4c0319e44cd319e105173d143f4407..324a602761695b8f369c129a0bf4e5e4588abb0b 100644 (file)
@@ -121,4 +121,8 @@ define PROFTPD_INSTALL_INIT_SYSTEMD
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/proftpd.service
 endef
 
+ifneq ($(BR2_PACKAGE_PROFTPD_BUFFER_SIZE),0)
+PROFTPD_CONF_OPTS += --enable-buffer-size=$(BR2_PACKAGE_PROFTPD_BUFFER_SIZE)
+endif
+
 $(eval $(autotools-package))