package/leveldb: turn snappy into an optional dependency
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 18 May 2020 05:22:01 +0000 (07:22 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 26 May 2020 20:49:31 +0000 (22:49 +0200)
snappy is not a mandatory dependency to build leveldb. Back when it
was introduced in Buildroot, as of version 1.18, the build logic
already made snappy an optional dependency.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/leveldb/Config.in
package/leveldb/leveldb.mk

index c767b88645a829f3a410831551f99a653b5ce7cc..c4279fcb64567055ea2f52030876da58cb7f8e44 100644 (file)
@@ -3,7 +3,6 @@ config BR2_PACKAGE_LEVELDB
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # C++11
        depends on BR2_TOOLCHAIN_HAS_THREADS
-       select BR2_PACKAGE_SNAPPY
        help
          LevelDB is a fast key-value storage library written at Google
          that provides an ordered mapping from string keys to string
index cf3c096f5d4db5b561f4b08fd7dfb16bd4b80003..684b618679cb4a2318a46201880248f45dc1c395 100644 (file)
@@ -9,9 +9,12 @@ LEVELDB_SITE = $(call github,google,leveldb,$(LEVELDB_VERSION))
 LEVELDB_LICENSE = BSD-3-Clause
 LEVELDB_LICENSE_FILES = LICENSE
 LEVELDB_INSTALL_STAGING = YES
-LEVELDB_DEPENDENCIES = snappy
 LEVELDB_CONF_OPTS = \
        -DLEVELDB_BUILD_BENCHMARKS=OFF \
        -DLEVELDB_BUILD_TESTS=OFF
 
+ifeq ($(BR2_PACKAGE_SNAPPY),y)
+LEVELDB_DEPENDENCIES += snappy
+endif
+
 $(eval $(cmake-package))