qt5quickcontrols: install examples to target
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Tue, 12 Jun 2018 12:32:00 +0000 (08:32 -0400)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Jun 2018 12:35:07 +0000 (14:35 +0200)
When BR2_PACKAGE_QT5BASE_EXAMPLES is set, the examples for this module
are installed in the staging directory but they are not shipped to the
target.

This commit copies the examples `quickcontrols' from the staging
directory to the target.

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5quickcontrols/qt5quickcontrols.mk

index 5517cc15374269eae187aad959d7508ff5029468..6e551d5a2702ae3268398f4a3c90787e68b6594d 100644 (file)
@@ -25,6 +25,12 @@ define QT5QUICKCONTROLS_INSTALL_STAGING_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install
 endef
 
+ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
+define QT5QUICKCONTROLS_INSTALL_TARGET_EXAMPLES
+       cp -dpfr $(STAGING_DIR)/usr/lib/qt/examples/quickcontrols $(TARGET_DIR)/usr/lib/qt/examples/
+endef
+endif
+
 ifeq ($(BR2_PACKAGE_QT5DECLARATIVE_QUICK)$(BR2_PACKAGE_QT5BASE_WIDGETS),yy)
 define QT5QUICKCONTROLS_INSTALL_TARGET_PRIVATEWIDGETS
        cp -dpfr $(STAGING_DIR)/usr/qml/QtQuick/PrivateWidgets $(TARGET_DIR)/usr/qml/QtQuick
@@ -43,6 +49,7 @@ define QT5QUICKCONTROLS_INSTALL_TARGET_CMDS
        cp -dpfr $(STAGING_DIR)/usr/qml/QtQuick/Extras $(TARGET_DIR)/usr/qml/QtQuick
        $(QT5QUICKCONTROLS_INSTALL_TARGET_PRIVATEWIDGETS)
        $(QT5QUICKCONTROLS_INSTALL_TARGET_LAYOUTS)
+       $(QT5QUICKCONTROLS_INSTALL_TARGET_EXAMPLES)
 endef
 
 $(eval $(generic-package))