qt5: Add an option to select default platform
authorJérôme Pouiller <jezz@sysmic.org>
Wed, 16 Jul 2014 15:58:51 +0000 (17:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Jul 2014 17:49:37 +0000 (19:49 +0200)
Whithout this path, default platform is automaticaly set (generally
set to "eglfs" as defined in
qt5base/mkspecs/devices/common/linux_device_pre.conf:1). This choice
is not always what the user would like. Thus, user have to manually
appends "-platform <BACKEND>" to command line when running any qt5
application.

This patch allows user to choose default platform explicitly.

[Thomas: slightly improve Config.in help text, from the suggestions
given by Yann E. Morin.]

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5base/Config.in
package/qt5/qt5base/qt5base.mk

index 24e5902c00949a3e3edafe6e83ad10efb1eea746..490ee3e09df70417bd14948b00025c51695c2f5e 100644 (file)
@@ -144,6 +144,17 @@ config BR2_PACKAGE_QT5BASE_EGLFS
 comment "eglfs backend available if OpenGLES and EGL are enabled"
        depends on !BR2_PACKAGE_HAS_LIBEGL || !BR2_PACKAGE_HAS_LIBGLES
 
+config BR2_PACKAGE_QT5BASE_DEFAULT_QPA
+       string "Default graphical platform"
+       help
+         Choose the default platform abstraction to use for graphical
+         applications (e.g xcb, linuxfb, eglfs, ...). If this is empty, the
+         default for your architecture will be used (usually this is eglfs).
+
+         You can get a list of supported platforms by running a Qt application
+         with the option "-platform help" on your target. You can choose a
+         different platform at runtime with the -platform option.
+
 config BR2_PACKAGE_QT5BASE_PRINTSUPPORT
        bool "print support module"
        select BR2_PACKAGE_QT5BASE_WIDGETS
index 618251eb528e77d1b7b623b466f4eb4d3dd3cc08..fecde131c5e0702e91c770ba46bfe3975bb824e4 100644 (file)
@@ -96,6 +96,9 @@ else
 QT5BASE_CONFIGURE_OPTS += -no-xcb
 endif
 
+QT5BASE_DEFAULT_QPA = $(call qstrip,$(BR2_PACKAGE_QT5BASE_DEFAULT_QPA))
+QT5BASE_CONFIGURE_OPTS += $(if $(QT5BASE_DEFAULT_QPA),-qpa $(QT5BASE_DEFAULT_QPA))
+
 ifeq ($(BR2_PACKAGE_QT5BASE_EGLFS),y)
 QT5BASE_CONFIGURE_OPTS += -opengl es2 -eglfs
 QT5BASE_DEPENDENCIES   += libgles libegl